Blog

“Elegant Grunge” WordPress theme

“Elegant Grunge” is an unwashed yet crisp WordPress theme inspired by wefunction.com. It features:

  • Layouts options
  • Support for custom background and header
  • Widget-ready footer
  • Optional full-width page template that removes the sidebar

screenshot.png


Get Elegant Grunge

If you like Elegant Grunge, please consider buying one of my products.

Version 1.1 has been updated to the WordPress.com version.

This version no longer contains automatic image framing, or a photoblog template, so if you wish to continue using these features, please use version 1.0.3.

Changes:

  • Layout updates and fixes
  • Fixed deprecated function calls and PHP errors
  • Code cleanup to match WordPress theme style guide: spacing, syntax, comments, package description
  • Added author comment highlighting
  • Added support for empty post title and styles for all heading sizes
  • Fixed bugs with theme options menus
  • Simplified custom functions and removed unneeded theme options
  • Remove custom header image support and use default WP header image functionality instead
  • Added image.php template
  • Added RTL language support
  • Changed post timestamp to use the WordPress global date format
  • Remove unused template files
  • Implement WordPress 3.0 features: Custom Menu, comment_form()
  • Added default WP style support: body_class(), post_class(), comment_class() and remove unneeded definition for EG_BODY_CLASS
  • Removed unneeded function_exists() calls
  • Simplified image display: no frames or photoblog page
  • Nicer typography and updated grunge images for sticky posts, trackbacks, and new date format
  • Styles for sticky posts
  • Added newer/older single post navigation links
  • Better class attributes to avoid collision with WP default classes (author, post, date, etc)
  • Remove sidebar logic check in every template (once in sidebar.php instead)

Note: If you have problems with this theme, please post your question at the WordPress forums. Please don’t contact me directly, as I don’t have the resources to help you.

Language Packs

Many thanks to contributors!

Casual German/Deutsch – by Markus Bischof

Formal/polite German/Deutsch – by André Heil

Italian/Italiano – by Paolo Lucciola

French/Français – by Arnaud Ball

Romanian – by Adrian Nitescu

Arabic/العربية – by Mena

Finnish/Suomi – by Antti

Turkish/Türkçe – by Mehmet

Brazilian Portuguese – by Jandeilson S. Barbosa

Spanish/Español – by José Vergara

Norwegian/Norsk – by Vipblogg

Russian/русский язык – by Sergey aka Cepxuo

Czech – by Bengo

Lithuanian – by Valentinas Bakaitis

Belorussian – by Marcis G./Galina Miklosic

Polish – by Grzegorz ‘ixcesal’ Lasecki

Dutch – by Rene (WPwebshop)

Indonesian/Bahasa Indonesia – by Kelayang

Filipino – by Mikael Riec

Danish/Dansk – by Morten Elm

Latvian – by Johannes Rau

To use these language packs, you must download the WordPress language pack first, copy it into wp-content/languages, then edit wp-config.php and set the WPLANG value to the appropriate language abbreviation (eg ‘fr_FR’). Then unzip the Elegant Grunge language pack into the wp-content/themes/elegant-grunge folder, and you’re set.

Community

WordPress Theme Elegant Grunge Template Addon for built-in WordPress GallerySebastian Graß

Paul Kaiser has written a great article on how to add navigation menus to older WordPress themes, using Elegant Grunge as an example.

, , , . Bookmark the permalink. Both comments and trackbacks are currently closed.

30 Comments

  1. Posted October 20, 2008 at 10:41 pm | Permalink

    Michael,

    Just found out what causes the error: use of Short Open tags.

    To use short open tags, it must be enabled in PHP.INI and by default the WAMP installation turn it off. It’s just a matter of defining, at PHP.INI:

    short_open_tag = On

    Hope this may help more people.

    Regards,

    ../vitor

  2. Posted October 20, 2008 at 10:53 pm | Permalink

    Ahh! Well found, Vitor, and thanks – I found the offending PHP short open tag; It’s an old, bad habit, using those things, and it looks like I’d missed one. Fixed now in the unofficial 20081020 release above, and will be rolled into the next official version after 0.4.2.

  3. Posted October 21, 2008 at 10:24 am | Permalink

    Hi Mike, thanks for the fantastic theme, looks slick as. I’m just having a slight problem with the sidebar displaying an extra space between content in the widgets, bad decription I know… If you could be so kind and point me in the right direction. I would be glad to provide more info should you need it. Thanks again mate.

  4. Posted October 21, 2008 at 10:30 am | Permalink

    Smooth: Thanks, I’m glad you like it! First thing, upgrade to the latest version, available above. If that doesn’t make your sidebar look to your liking, you’ll need to jump into style.css (Admin, Design, Theme Editor, style.css). Then scroll down to the Sidebar section, and look for the margin-bottom property of #sidebar ul li. Then, change it from the current 25px to whatever you like.

    I hope that answers your question!

  5. Posted October 21, 2008 at 11:18 am | Permalink

    Awesome! Version 0.4.3 has fixed this for me. Thanks for the quick reply and all your hard work. Cheers.

  6. Trevor
    Posted October 21, 2008 at 3:45 pm | Permalink

    Michael….how can I update my current theme to the latest version? Trev

  7. Posted October 22, 2008 at 5:32 pm | Permalink

    I have to say, I’m new to wordpress , and just in the process of setting up my site http://www.fullpen.com (Still being setup)and I have to say Hands down, I like what your theme has to offer, and look. Any suggestions I had have already been address in the Post releases.

    The only Suggestion: I would love if I could use the left side of the screen for more links (3 columns)

    I have added spam protection by way of “Simple Math” questions at the end of comments, and Drop caps as plug in.

  8. Posted October 22, 2008 at 6:55 pm | Permalink

    Hey Micheal If i uploaded the translated version of the theme and give it to can you update it with the every updated English version?, or it will be as if you doing the double, i only said that because of the patching you mentioned i guessed it will be better than translating the theme every time… and will be available in another language ..

    Thank you, Mena

  9. Posted October 22, 2008 at 7:05 pm | Permalink

    Okay,I will translate the new version now

  10. Posted October 22, 2008 at 8:38 pm | Permalink

    Hi Again,

    here is the translated version, you can look at it in http://www.one4v.com/blogs

    Link : Here

    I have used a CSSMirro Tool to mirror all the theme except the translation that was manual

  11. Posted October 23, 2008 at 9:23 am | Permalink

    Thank you so much, the ability to add stuff to the header as a setting is greatly helpful! I’m using right now for linking an OpenID to my blog.

  12. Posted October 24, 2008 at 2:11 am | Permalink

    Do the theme support LightBox plug-in for viewing photos in posts not only PhotoBlog

  13. Cynthia
    Posted October 24, 2008 at 2:32 pm | Permalink

    Smiley faces are getting the automatic photo frame put around them :P looks a little bizarre!

    Also, a long tagline next to the site title doesn’t come out right. Part of the text ends up showing next to the first blog entry.

    Otherwise, really like it!

  14. Posted October 24, 2008 at 2:33 pm | Permalink

    Thanks Cynthia!

    See the notes about version 0.4 above about smileys.

    Tagline: Thanks, I’ll take a look at that for next version!

  15. Posted October 24, 2008 at 3:54 pm | Permalink

    这是一个非常漂亮的主题,我已经推荐给我的朋友使用了,感谢Micheal 的共享:)

  16. SeMa
    Posted October 25, 2008 at 8:54 am | Permalink

    Hi there. Really nice theme but I’m having some troubles. I’m trying to put some random quotes ()just below the blog-name in the header. I don’t really understand what all the code means, so I’m doing some ‘trial and error’ there :)

    Any idea how I can add this?

    Thanks

  17. Posted October 25, 2008 at 10:41 am | Permalink

    Hi Sema,

    Absolutely -add your tag to print the quotes just beneath the line:

        <blockquote><tt>&lt;span id="blog-description"&gt;&lt;?php bloginfo('description'); ?&gt;&lt;/span&gt;</tt></blockquote>
    

    Wrap it in a span with an id so you can style it:

    <span id="quotes"><?php random_quote(); ?></span>

    Then add a corresponding item in style.css; something like

    #quotes {   color: white;   font-size: 0.8em;   ...your extra style stuff here... }
  18. Posted October 26, 2008 at 1:50 am | Permalink

    Thanks,beautiful theme!

  19. Mike
    Posted October 26, 2008 at 3:04 am | Permalink

    Hey Michael,

    I love the theme and I am currently using it on my website, but I have come across a problem when I try to create new pages. It seems that the body gets cut off at the bottom. Any ideas how I could fix this?

    Thanks!

  20. SeMa
    Posted October 26, 2008 at 3:13 am | Permalink

    Hi again Michael, well, it’s working now but not 100% :) The quote is below the dark-grey part – I wanted it to be right below the blog-name, i.e. (your blog) below the big white “Michael Tyson” up there.

    Hope you can help.

    Thanks

  21. Posted October 26, 2008 at 5:01 am | Permalink

    I love that theme great work, i’m useing it myself.

  22. Posted October 26, 2008 at 10:10 am | Permalink

    Thanks guys!

    Sema: That’s right, you need to apply some css to make it look the way you want. I suggest you check out a couple of quick css tutorials or find a reference, but for the short term, try adding

    position: relative; top: -150px;

    to your #quote CSS block. And alter the ‘top’ value until it’s where you want.

    Mike: Hmm… Can you give me a URL to an example page where this happens? Is it in all browsers or in just one? Are you using the latest version?

  23. Posted October 26, 2008 at 2:28 pm | Permalink

    Hi Michael, I absolutely love this design and am using it for my site. I came across a problem of putting a youtube video in my post. It doesn’t post with the video, just with the html. How can I fix that? Thanks

  24. Posted October 27, 2008 at 1:02 am | Permalink

    hey Michael

    I love your design and been using it since version 0.1!! However, I ran into a background shadow image issue using NextGen gallery. Your css frame section causing the thumbnails off the center and the background shadow images does not match with thumbnails. I also notice that you also using NextGen and does not use frame css with it. Are you running same issue as me?

    I had to comment out frame part in order to work. Are you planning to fix this in future version?

    Any way, I love your work and good luck on your PhD.

    Thanks

    Austin

  25. SeMa
    Posted October 27, 2008 at 2:34 am | Permalink

    It’s me again :) Thanks for the help, position: absolute; top: 160px; left: 120px; worked. cheer

  26. Posted October 27, 2008 at 7:59 am | Permalink

    Hi Austin, Glad you like it!

    Just disable frames for the page/post with NextGEN on it – that’s what I do. No commenting out necessary: Just untick the box. Or is it tick? I can’t remember…

    I wasn’t planning on implementing support for NextGEN, but I could look into it.

  27. Posted October 27, 2008 at 11:06 am | Permalink

    Hey Michael, I really love this theme and have been poking it a bit. There’s only one thing I want to do to it left and I’ll be happy!

    I’m not comfortable with the large amount of space between the title of a post and its content. Is there a way to make it about half of that? Thanks!!!

  28. Posted October 27, 2008 at 11:35 am | Permalink

    Hi Gideon,

    That’s easy – open up the style.css (either in the editor of your choice, or through WP admin), scroll down to the ‘Content’ section, and change the margin-bottom setting for ‘h2’

  29. Posted October 27, 2008 at 12:24 pm | Permalink

    Excellent! Also, just for anyone else who may do this, the .post.author area needs the “top:-80px” reduced as well (changed to -50, etc.) Some tweaking got it done! Thanks a lot!

  30. Mike
    Posted October 28, 2008 at 3:34 am | Permalink

    Hey Michael,

    I haven’t had the issue while using Mozilla Firefox…however if I use IE6 or IE7 the issue with pages not displaying properly happens.

    Here is an example page…

    http://www.thehorrormoviecritic.com/?page_id=2